chroot ile Gentoo 20150820 KDE Kurulumu



Şu an kullanmakta olduğum Arch Linux sistem üzerinden chroot ile güncel Gentoo kurulumu yapacağım. Uzun ve bekletici bir süreç. Vaktiniz varsa buyurun siz de başlayın.



Şu an kullandığım sistem 64 bit Arch Linux. Görsel araçlar ve kopyala yapıştır gibi pek çok yardımı olacağı için canlı kalıp yerine başka sistem üzerinden kurulum yapıyorum. Şu an kullandığım sistem ile derlemeleri yapacağım, bittiğinde bilgisayarı yeniden başlatacağım ve kullanıma hazır bir Gentoo olacak.

Gparted türü bir araçla 20 GB'lik mantıksal bir disk bölümü ayırmak işimizi görecektir. Benim /dev/sda8 bölümüm hazır.

mkdir /mnt/gentoo
mount /dev/sda8 /mnt/gentoo
cd /mnt/gentoo

Buraya kuruluma başlıyorum.

wget http://ftp.linux.org.tr/gentoo/releases/amd64/autobuilds/current-stage3-amd64/stage3-amd64-20150820.tar.bz2

tar -xjpf stage3*

Birkaç bağlama

mount -o rbind /dev /mnt/gentoo/dev
mount -t proc none /mnt/gentoo/proc
mount -o bind /sys /mnt/gentoo/sys
mount -o bind /tmp /mnt/gentoo/tmp

Chroot internet bağlantısı da gerekli:

cp /etc/resolv.conf /mnt/gentoo/etc

Sisteme girelim:

chroot . ./bin/bash

Kurulumu yarım bırakmanız gerekirse uçbirimi direk kapatmanız herhangi bir sorun çıkarmayacaktır. Bilgisayarı yeniden başlatıp tekrar devam ettiğiniz zaman şunlarla başlayın:


Normalde ortamı ayarlamasını beklerdim ama bunu istedi:

mkdir /usr/portage/metadata
echo 'masters = gentoo' >> /usr/portage/metadata/layout.conf

Artık sorunsuz ayarlar:

source /etc/profile
mkdir /usr/portage
env-update

emerge --sync

Paketler de hazır.

passwd

useradd -m -G audio,cdrom,usb,video,wheel -s /bin/bash linuxdunyam

passwd linuxdunyam

Şimdi profil seçelim.

eselect profile list


Gentoo'yu openrc ile kuralım. KDE ortamını istiyorum. Yani 6 numara.

eselect profile set 6

nano /etc/portage/make.conf

dosyasında USE satırındaki tırnakların içine

USE="bindist mmx sse sse2 kde qt4 -systemd alsa caps dbus gdbm glib gtk pulseaudio udev usb X wifi"

Bir satır ekleyin:

INPUT_DEVICES="keyboard evdev mouse"

Ve ekran kartınız ne ise:

VIDEO_CARDS="nouveau"
VIDEO_CARDS="radeon"
VIDEO_CARDS="intel"

Eklenecek satırlar:

GRUB_PLATFORMS="pc"
LINGUAS="tr"

CFLAGS satırını bu şekle getirin:

CFLAGS="-O2 -march=native -pipe"

Ctrl+O, Ctrl+X

USE bayraklarının değişikliğine göre sistemi düzenlesin:

emerge --changed-use --deep @world

Yaklaşık 5 saat sürüyor.  Bu daha da fazla sürecek:

emerge --ask xorg-server kde-apps/kdebase-meta kde-base/kdebase-startkde wpa_supplicant grub xdm dolphin alsa pulseaudio kde-apps/kdenetwork-meta firefox sudo gksu dhcpcd sudo gksu kde-misc/network-management kde-misc/plasma-nm net-misc/networkmanager

echo 'linuxdunyam ALL=(ALL) ALL'>>/etc/sudoers

Ekran kartı için birini seçmeniz gerekir.

emerge xf84-video-nouveau
emerge ati-drivers
emerge xf86-video-intel

Görüntü yöneticisi:

nano /etc/conf.d/xdm

DISPLAYMANAGER="kdm"

rc-update add xdm default

Çağıran kimse yok diye:

rc-update add dbus default
rc-update add NetworkManager default

Fazla uygulama olmadan temel KDE ortamı hazır.

Şimdi ifconfig deyin. Gelen cevaptaki e ile başlayan kablolu, w ile başlayan kablosuz bağdaştırıcınız. Ağ yapılandırması:

nano -w /etc/conf.d/net

config_eth0="dhcp"
config_wlan0="dhcp"
modules="wpa_supplicant"

Arayüzler bağlansın diye:

ln -s net.lo net.eth0
rc-update add net.eth0 default

ln -s net.lo net.wlan0
rc-update add net.wlan0 default

Açılışta klavye:

mkdir /etc/X11/xorg.conf.d
nano -w /etc/X11/xorg.conf.d/01-keyboard-layout.conf

Section "InputClass"
 Identifier "keyboard-layout"
 MatchIsKeyboard "on" 
 Driver "evdev"
 Option "XkbLayout" "tr"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbVariant" "" 
EndSection

echo 'exec startkde' >> /home/KULLANICIADINIZ/.xinitrc

ls /usr/share/zoneinfo/Turkey /etc/localtime
echo "Turkey" > /etc/timezone

nano -w /etc/locale.gen

dosyasında baştaki iki İngilizce ile

tr_TR ISO-8859-9
tr_TR.UTF-8 UTF-8

gerekli.

locale-gen

Kerneli ayarlayalım:

emerge -av sys-kernel/gentoo-sources sys-kernel/linux-firmware

cd /usr/src/linux

make defconfig

Benim kablosuz kartım Intel 4965AGN

lspci diyerek siz de aklınızda tutun.

make menuconfig

Şimdi burada bilgisayarınızdaki kablolu ve kablosuz ağ bağdaştırıcınızı bulmanız gerekir. Dikkat etmeniz gereken nokta, M harfi ile modül olarak eklemeniz. Mesela bende:


Modüller:

Device Drivers > Network device support > Wireless LAN
Device Drivers > Network device support > Ethernet driver support

yollarında. Ayrıca ekran kartınız için modülü bulalım:

Device Drivers > Graphics support > Direct Rendering Manager > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)


ATI Radeon, Intel veya Nouveau mevcut. Burada dikkat etmeniz gereken, modülü kernelle birlikte derlemeniz için * seçeneği ile işaretlemek.

Exit, Exit, Exit ve Save. Derleyelim:

make -j2

Modül halinde derlediğimiz ağ bağdaştırıcıları burada yükleyecek ve kerneli atacak:

make modules_install
make install

grub-install /dev/sda

exit diyelim. Gentoo grub'u yönetince diğer sistemleri görmedi. Uğraşmadan grub'u Arch'a alalım.

umount -R /mnt/gentoo
grup-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg

Ekran kartı sürücüsü düzgün çalışan, oturum açma ekranı olan ve ister kablolu ister kablosuz internete bağlı KDE karşımda. Bir günümü almasına değdi mi? Evet.



Esas uğraştırıcı kısım şimdi başlıyor. Kolay gelsin.

28 yorum :

  1. 9GB'lık bir alana kurulum yapmam mümkün mü?

    YanıtlaSil
    Yanıtlar
    1. Kde derlendiği esnada on gb'yi aşkın yer gerekecektir. gentoolkit'i kurup derlemeleri teker teker yaparken eclean-dist eclean-pkg diye diye giderseniz yetebilir.

      Sil
    2. Xfce ile birlikte kaç GB alan lazım olur?

      Sil
    3. 9 gb yetebilir. Use bayrakları değişecektir.

      Sil
    4. Peki bu işlem sonucunda Arch Linux silinecek mi, yoksa dual boot mu olacak?

      Sil
    5. Başlangıç seçeneklerine Gentoo da eklenecek. Bende 6 sistem kurulu iken 7'ye çıktı.

      Sil
    6. 7 sistem biraz fazla değil mi? Hepsini de kullanıyor musunuz?

      Sil
    7. İşim gereği windows ve gündelik işlerde arch linuxu kullanıyorum. Diğer sistemler deneme amaçlı.

      Sil
  2. root@ata ata]# mount /dev/sda3 /mnt/gentoo
    [root@ata ata]# cd /mnt/gentoo
    [root@ata gentoo]# tar -xjpf stage3*
    [root@ata gentoo]# mount -o rbind /dev /mnt/gentoo/dev
    [root@ata gentoo]# mount -t proc none /mnt/gentoo/proc
    [root@ata gentoo]# mount -o bind /sys /mnt/gentoo/sys
    [root@ata gentoo]# mount -o bind /tmp /mnt/gentoo/tmp
    [root@ata gentoo]# cp /etc/resolv.conf /mnt/gentoo/etc
    [root@ata gentoo]# chroot . ./bin/bash
    chroot: failed to run command `./bin/bash': Çalıştırılabilir biçem hatası
    [root@ata gentoo]#



    bu hatayı alıyorum sebebi ne olabilir arch ve manjaro kullanıcısıyım

    YanıtlaSil
    Yanıtlar
    1. Kullandığınız sistem ile chroot yapacağınız sistemin ikisi de aynı mimaride olmalı. 32 ise 32, 64 ise 64 bit. Eğer aynı ise indirdiğiniz stage3 dosyası hatalı inmiş olabilir. /bin/bash dosyası var mı bir bakın.

      Sil
    2. make menuconfig komutuna kadar geldim 2 hata diyor evet tar.gz inerken sorun olmuş o durumu aştım

      Sil
  3. emerge --changed-use --deep @world komutu kısa süre sonra bu hatayı veriyor x11-libs/pixman-0.32.8::gentoo failed

    YanıtlaSil
    Yanıtlar
    1. Son aylarda profil listesi ve use bayraklarında değişiklik olup olmadığını takip etmedim. Kde'yi openrc ile mi seçtiniz? emerge --info der misiniz?

      Sil
    2. System uname: Linux-4.1.18-1-MANJARO-i686-Intel-R-_Core-TM-2_Duo_CPU_T6600_@_2.20GHz-with-gentoo-2.2
      KiB Mem: 3103260 total, 322300 free
      KiB Swap: 5105660 total, 5105512 free
      Timestamp of repository gentoo: Mon, 22 Feb 2016 19:30:01 +0000
      sh bash 4.3_p42-r1
      ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
      app-shells/bash: 4.3_p42-r1::gentoo
      dev-lang/perl: 5.20.2::gentoo
      dev-lang/python: 2.7.10-r1::gentoo, 3.4.3-r1::gentoo
      dev-util/pkgconfig: 0.28-r2::gentoo
      sys-apps/baselayout: 2.2::gentoo
      sys-apps/openrc: 0.19.1::gentoo
      sys-apps/sandbox: 2.10-r1::gentoo
      sys-devel/autoconf: 2.69::gentoo
      sys-devel/automake: 1.14.1::gentoo, 1.15::gentoo
      sys-devel/binutils: 2.25.1-r1::gentoo
      sys-devel/gcc: 4.9.3::gentoo
      sys-devel/gcc-config: 1.7.3::gentoo
      sys-devel/libtool: 2.4.6::gentoo
      sys-devel/make: 4.1-r1::gentoo
      sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
      sys-libs/glibc: 2.21-r1::gentoo
      Repositories:

      gentoo
      location: /usr/portage
      sync-type: rsync
      sync-uri: rsync://rsync.gentoo.org/gentoo-portage
      priority: -1000

      ACCEPT_KEYWORDS="x86"
      ACCEPT_LICENSE="* -@EULA"
      CBUILD="i686-pc-linux-gnu"
      CFLAGS="-O2 -march=i686 -pipe"
      CHOST="i686-pc-linux-gnu"
      CONFIG_PROTECT="/etc"
      CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
      CXXFLAGS="-O2 -march=i686 -pipe"
      DISTDIR="/usr/portage/distfiles"
      FCFLAGS="-O2 -march=i686 -pipe"
      FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
      FFLAGS="-O2 -march=i686 -pipe"
      GENTOO_MIRRORS="http://distfiles.gentoo.org"
      LANG="tr_TR.utf8"
      LDFLAGS="-Wl,-O1 -Wl,--as-needed"
      PKGDIR="/usr/portage/packages"
      PORTAGE_CONFIGROOT="/"

      Sil
    3. Ayrı bir uçbirimde manjaroyu güncelleyip sistemi yeniden başlatın. Yani kernel 4.4'e geçin. İlk ekran görüntüsünde yazan komutların ardından kaldığınız komuttan devam edebilirsiniz.

      Sil
    4. manjaro kernel ben yükseltmezsem güncelleme ile yükselmez lts kernel kullanırım ben kısaca yükseltmek zorundamıyım ?

      Sil
    5. Pixman ile ilgili sorunlarda genelde kernel değiştirmeyi önermişler. Görüntü ile ilgili bir sorun olduğu için bence deneyin.

      Sil
    6. 4.4 yaptım manuel olarak yeniden komutu çalıştırıyorum umarım bu defa olur .Minimal iso ilede sorun disk bölmede yaşamıştım
      neyse deneyip donerim ilgi alakanıza teşekkürler

      Sil
  4. .32.8/work/pixman-0.32.8/test/region-translate-test.c
    {standard input}: Assembler messages:
    {standard input}:88: Error: junk `@indntpoff' after expression
    {standard input}:228: Error: junk `@indntpoff' after expression
    {standard input}:406: Error: junk `@indntpoff' after expression
    {standard input}:407: Error: junk `@indntpoff' after expression
    Makefile:1033: recipe for target 'region-test.o' failed
    make[2]: *** [region-test.o] Error 1
    make[2]: *** Waiting for unfinished jobs....
    make[2]: Leaving directory '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8-abi_x86_32.x86/test'
    Makefile:502: recipe for target 'all-recursive' failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8-abi_x86_32.x86'
    Makefile:409: recipe for target 'all' failed
    make: *** [all] Error 2
    * ERROR: x11-libs/pixman-0.32.8::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=x11-libs/pixman-0.32.8::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=x11-libs/pixman-0.32.8::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/x11-libs/pixman-0.32.8/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/x11-libs/pixman-0.32.8/temp/environment'.
    * Working directory: '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8-abi_x86_32.x86'
    * S: '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8'

    >>> Failed to emerge x11-libs/pixman-0.32.8, Log file:

    >>> '/var/tmp/portage/x11-libs/pixman-0.32.8/temp/build.log'

    * Messages for package media-sound/pulseaudio-7.1:

    * Unable to find kernel sources at /usr/src/linux
    * Unable to calculate Linux Kernel version for build, attempting to use running version

    * Messages for package sys-apps/coreutils-8.23:

    * Make sure you run 'hash -r' in your active shells.
    * You should also re-source your shell settings for LS_COLORS
    * changes, such as: source /etc/profile

    * Messages for package x11-libs/pixman-0.32.8:

    * ERROR: x11-libs/pixman-0.32.8::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=x11-libs/pixman-0.32.8::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=x11-libs/pixman-0.32.8::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/x11-libs/pixman-0.32.8/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/x11-libs/pixman-0.32.8/temp/environment'.
    * Working directory: '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8-abi_x86_32.x86'
    * S: '/var/tmp/portage/x11-libs/pixman-0.32.8/work/pixman-0.32.8'

    * Regenerating GNU info directory index...
    * Processed 108 info files.
    * After world updates, it is important to remove obsolete packages with
    * emerge --depclean. Refer to `man emerge` for more information.

    YanıtlaSil
  5. System uname: Linux-4.4.2-1-MANJARO-i686-Intel-R-_Core-TM-2_Duo_CPU_T6600_@_2.20GHz-with-gentoo-2.2
    KiB Mem: 3102968 total, 1305628 free
    KiB Swap: 5105660 total, 5105660 free
    Timestamp of repository gentoo: Mon, 22 Feb 2016 19:30:01 +0000
    sh bash 4.3_p42-r1
    ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
    app-shells/bash: 4.3_p42-r1::gentoo
    dev-lang/perl: 5.20.2::gentoo
    dev-lang/python: 2.7.10-r1::gentoo, 3.4.3-r1::gentoo
    dev-util/pkgconfig: 0.28-r2::gentoo
    sys-apps/baselayout: 2.2::gentoo
    sys-apps/openrc: 0.19.1::gentoo
    sys-apps/sandbox: 2.10-r1::gentoo
    sys-devel/autoconf: 2.69::gentoo
    sys-devel/automake: 1.14.1::gentoo, 1.15::gentoo
    sys-devel/binutils: 2.25.1-r1::gentoo
    sys-devel/gcc: 4.9.3::gentoo
    sys-devel/gcc-config: 1.7.3::gentoo
    sys-devel/libtool: 2.4.6::gentoo
    sys-devel/make: 4.1-r1::gentoo
    sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
    sys-libs/glibc: 2.21-r1::gentoo
    Repositories:

    gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    masters: gentoo
    priority: -1000

    ACCEPT_KEYWORDS="x86"
    ACCEPT_LICENSE="* -@EULA"
    CBUILD="i686-pc-linux-gnu"
    CFLAGS="-O2 -march=native -pipe"
    CHOST="i686-pc-linux-gnu"
    CONFIG_PROTECT="/etc"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
    CXXFLAGS="-O2 -march=native -pipe"
    DISTDIR="/usr/portage/distfiles"
    FCFLAGS="-O2 -march=i686 -pipe"
    FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
    FFLAGS="-O2 -march=i686 -pipe"
    GENTOO_MIRRORS="http://distfiles.gentoo.org"
    LANG="tr_TR.utf8"
    LDFLAGS="-Wl,-O1 -Wl,--as-needed"
    PKGDIR="/usr/portage/packages"
    PORTAGE_CONFIGROOT="/"

    YanıtlaSil
    Yanıtlar
    1. pacman -S linux44-headers

      Sil
    2. bu zaten kurulu yeniden kurdum bir daha deneyeyim

      Sil
  6. sorun devam ediyor çok ilginçtir ama

    YanıtlaSil
    Yanıtlar
    1. Ben bu kurulumu Ağustos ayında yapmıştım. Açıkçası, kurulum yapmak veya gentoo kullanmaktan ziyade bu tür sorunlarla uğraşmak daha çok keyif veriyor. Yapbozun parçalarını bulmaca çözerek buluyormuşum gibi. Kernel başlık dosyalarının eksik olduğunu düşünüyorum.

      Sil
  7. stage3-i686-20160216.tar.bz2 2016-02-16 18:29 227M

    bu paket kullandığım acaba bunda sorun olabilirmi başkada yok gördüğüm güncel olanı

    http://distfiles.gentoo.org/releases/x86/autobuilds/current-stage3-i686/

    YanıtlaSil
    Yanıtlar
    1. Genelde haftalık düzende sık sık güncellenir. Eğer sorun fark etselerdi ilk fırsatta yenisini dağıtırlardı.

      Sil
    2. yani doğru paket dimi artık kendimden şüpheye düştüm 20 dakikada arch kuruyorum bütün gündür bu kurulum hatalarını düzetlttim kafa uçtu neyse yarın salim kafayla deneyeyim ilgi alakana teşekkürler

      Sil
    3. sorun arcda olduğu gibi türkçe karakter sorunu şu komut sorunumu çözdü aynı sorunu yaşayanlara bilgi olsun

      LANG=C emerge --changed-use --deep @world

      Sil